Possible loading issues
Incident Report for iClicker Cloud
Resolved
All systems have returned to normal. Our team will continue to monitor performance.
Posted Feb 26, 2021 - 11:38 EST
Investigating
Our team is currently investigating reports of errors or degraded performance on the Instructor and Student interfaces.
Posted Feb 26, 2021 - 11:30 EST
This incident affected: iClicker Cloud: Instructor Desktop Application, iClicker Cloud: Instructor Website, iClicker Student: iOS App, iclicker Student: Android App, and iClicker Student: Website.