Amazon Web Services (AWS) Service degradation
Incident Report for iClicker Cloud
Resolved
Amazon reported at 6:42 PM ET on 6/13/23 that their services have been restored. All iClicker systems are back to normal operation.
Posted Jun 14, 2023 - 08:49 EDT
Investigating
Amazon Web Services (AWS) is currently experiencing a service degradation which is affecting iClicker LMS integrations. More information regarding the AWS outage can be found on Amazon's status page https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 17:00 EDT