Degradation of Services

Incident Report for iClicker Cloud

Resolved

Normal services have been restored. We will continue to closely monitor the system.
Posted Aug 27, 2025 - 14:01 EDT

Investigating

We are investigating a degradation of services first noticed around 11:45 am eastern time. We are actively investigating and working to stabilize the system.
Posted Aug 27, 2025 - 12:17 EDT