iClicker Cloud degraded performance
Incident Report for iClicker Cloud
Resolved
Amazon Web Services reports that all services are back online and our internal testing has confirmed that iClicker is back online and fully functional. Thank you for your patience While we worked through this with our hosting partner.
Posted Dec 07, 2021 - 20:07 EST
Monitoring
Amazon Web Services have executed a mitigation which is beginning to show service recovery. We are continuing to monitor iClicker's applications as AWS is restored. AWS is still working towards full service recovery and we expect further updates on this incident.
Posted Dec 07, 2021 - 17:43 EST
Update
The AWS team reports issues are ongoing and their continued efforts to resolve are still underway. We will post more information as we receive it. You can also review updates at: https://status.aws.amazon.com/.
Posted Dec 07, 2021 - 15:29 EST
Update
The AWS team reports issues are ongoing and their continued efforts to resolve are still underway.
Posted Dec 07, 2021 - 13:19 EST
Identified
We've received an update from AWS that they have identified the root cause and are actively working towards recovery.
Posted Dec 07, 2021 - 11:54 EST
Investigating
iClicker is currently being impacted by Amazon Web Services (AWS) issues that may affect the ability to run activities or view course information in the online gradebook. We're sorry for the disruption and will update this status as we receive more resolution information.
Posted Dec 07, 2021 - 11:20 EST
This incident affected: iClicker Cloud: Instructor Desktop Application, iClicker Cloud: Instructor Website, iClicker Student: iOS App, iclicker Student: Android App, iClicker Student: Website, and Administration and Analytics.