iClicker Student web app purchase difficulties
Incident Report for iClicker Cloud
Resolved
As of 4:03pm Eastern time the issue has been resolved. Any students whose transactions failed should be able to retry as needed.
Posted Sep 07, 2022 - 16:55 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 07, 2022 - 16:30 EDT
Investigating
We have become aware that some students are experiencing errors while trying to purchase subscription time through the student.iclicker.com web app interface. This does not impact purchases made through any other method, including the mobile apps. Our team is investigating.

All services remain functional at this time.
Posted Sep 07, 2022 - 16:11 EDT