iClicker Cloud degraded performance
Incident Report for iClicker Cloud
Postmortem

On the night of March 10, we deployed changes to our infrastructure to address the root cause of these stability issues. In addition, a revised iOS student app was released on March 11 to address further concerns. It is recommended that all students using the iOS app update as soon as possible for the best classroom experience.

Posted Mar 11, 2021 - 21:58 EST

Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 19:33 EST
Monitoring
Performance levels are returning to normal. We will continue to monitor service status.
Posted Mar 10, 2021 - 15:36 EST
Update
Our team has identified the root cause and is working towards a resolution.
Posted Mar 10, 2021 - 14:20 EST
Identified
Our team is investigating slowness on some iClicker Cloud services. The issue has been identified. Our team continues to work on deploying a fix.
Posted Mar 10, 2021 - 09:15 EST
This incident affected: iClicker Cloud: Instructor Desktop Application, iClicker Cloud: Instructor Website, iClicker Student: iOS App, iclicker Student: Android App, iClicker Student: Website, and Administration and Analytics.